Conditionnelles, fonction SI() TAB03

Cet exercice concerne la fonction conditionnelle SI() dans un logiciel tableur. Il s’agit de tester cette fonction sur plusieurs exemples puis d’imbriquer plusieurs conditionnelles pour enchaîner les tests logiques.

Aperçu de l'exercice TAB03

Consignes de l’exercice

Téléchargez le fichier de travail ci-dessous.

Pour télécharger un fichier, faites un clic droit sur le fichier désiré et choisissez l’option Télécharger.
Pour télécharger plusieurs fichiers, sélectionnez les fichiers désirés puis cliquez sur Télécharger les sélectionnés. Les fichiers seront téléchargés sous la forme d’une archive .zip. Veillez à bien extraire le contenu de l’archive avant de commencer à travailler.

Pour chacune des questions suivantes, vous devrez compléter la colonne Formule en utilisant une formule conditionnelle.

Syntaxe de la fonction SI( ) :

=SI(Test logique ; Si vrai ; Si faux)

Exemple d’utilisation de la fonction SI :

=SI(A1=1 ; "A1 est égale à 1" ; "A1 est différente de 1")

Feuille de calcul Conditionnelles

Activez la première feuille de calcul nommée Conditionnelles.

Tableau 1.1 : Saisissez la formule permettant d’afficher la valeur la plus grande entre Valeur 1 et Valeur 2.

A
B
C
4
Valeur 1
Valeur 2
Formule
5
15
18
18
6
13
11
13
7
23
11
23
Solution :

Voici les formules à saisir afin d’obtenir le résultat attendu.

A
B
C
4
Valeur 1
Valeur 2
Formule
5
15
18
=SI(A5>B5;A5;B5)
6
13
11
=SI(A6>B6;A6;B6)
7
23
11
=SI(A7>B7;A7;B7)

Notez qu’il aurait été plus simple d’utiliser la formule =MAX(A5:B5) pour obtenir la valeur la plus élevée.

Tableau 1.2 : Saisissez la formule permettant d’afficher la valeur la plus petite entre Valeur 1 et Valeur 2.

A
B
C
10
Valeur 1
Valeur 2
Formule
11
17
23
17
12
11
8
8
13
29
20
20
Solution :

Voici les formules à saisir afin d’obtenir le résultat attendu.

A
B
C
10
Valeur 1
Valeur 2
Formule
11
17
23
=SI(A11<B11;A11;B11)
12
11
8
=SI(A12<B12;A12;B12)
13
29
20
=SI(A13<B13;A13;B13)

Notez qu’il aurait été plus simple d’utiliser la formule =MIN(A11:B11) pour obtenir la valeur la plus élevée.

Tableau 1.3 : Saisissez la formule permettant d’afficher le texte Max si la valeur est égale à 100 et d’afficher la valeur pour les autres cas.

A
B
16
Valeur
Formule
17
15
15
18
100
Max
19
23
23
Solution :

La précaution à prendre pour cette question est de penser à ajouter des guillemets autour du texte.

A
B
16
Valeur
Formule
17
15
=SI(A17=100; »Max »;A17)
18
100
=SI(A18=100; »Max »;A18)
19
23
=SI(A19=100; »Max »;A19)

Tableau 1.4 : Saisissez la formule permettant d’afficher le texte Ajourné pour les étudiants qui ont moins de 10 et Admis pour les autres.

A
B
C
22
Étudiant
Note
Formule
23
Bidule
13
Admis
24
Machin
10
Admis
25
Truc
9
Ajourné
Solution :

Voici les formules à saisir afin d’obtenir le résultat attendu.

A
B
C
22
Étudiant
Note
Formule
23
Bidule
13
=SI(B23<10; »Ajourné »; »Admis »)
24
Machin
10
=SI(B24<10; »Ajourné »; »Admis »)
25
Truc
9
=SI(B25<10; »Ajourné »; »Admis »)

Tableau 1.5 : Saisissez la formule permettant d’afficher le texte Admis pour les étudiants 10 ou plus et Ajourné pour les autres.

A
B
C
28
Étudiant
Note
Formule
29
Bidule
15
Admis
30
Machin
10
Admis
31
Truc
8
Ajourné
Solution :

Voici les formules à saisir afin d’obtenir le résultat attendu.

A
B
C
28
Étudiant
Note
Formule
29
Bidule
15
=SI(B29>=10; »Admis »; »Ajourné »)
30
Machin
10
=SI(B30>=10; »Admis »; »Ajourné »)
31
Truc
8
=SI(B31>=10; »Admis »; »Ajourné »)

Tableau 1.6 : Saisissez la formule permettant d’appliquer une ristourne de 10 avec le code A et de 20 avec le code B.

A
B
C
34
Prix
Ristourne
Formule
35
100
A
90
36
100
B
80
37
60
B
50
Solution :

Voici les formules à saisir afin d’obtenir le résultat attendu.

A
B
C
34
Prix
Ristourne
Formule
35
100
A
=SI(B35= »A »;A35-10;A35-20)
36
100
B
=SI(B36= »A »;A36-10;A36-20)
37
60
B
=SI(B37= »A »;A37-10;A37-20)

Cette formule pourrait être simplifiée =A35+SI(B35="A";-10;-20)

Tableau 1.7 : Saisissez la formule permettant d’appliquer d’effectuer une addition ou une soustraction entre les Valeur 1 et Valeur 2 en fonction du contenu de la colonne Opération.

A
B
C
D
40
Valeur 1
Opération
Valeur 2
Formule
41
30
Plus
10
40
42
30
Moins
20
10
43
50
Moins
8
42
Solution :

Voici les formules à saisir afin d’obtenir le résultat attendu.

A
B
C
D
40
Valeur 1
Opération
Valeur 2
Formule
41
30
Plus
10
=SI(B41= »Plus »;A41+C41;A41-C41)
42
30
Moins
20
=SI(B42= »Plus »;A42+C42;A42-C42)
43
50
Moins
8
=SI(B43= »Plus »;A43+C43;A43-C43)

Tableau 1.8 : Saisissez la formule permettant d’afficher le texte Paire pour les valeurs paires et Impaire pour les autres.

A
B
46
Valeur
Formule
47
10
Paire
48
5
Impaire
49
8
Paire
Solution :

Voici les formules à saisir afin d’obtenir le résultat attendu.

A
B
46
Valeur
Formule
47
10
Paire
48
5
Impaire
49
8
Paire

Feuille de calcul Conditionnelles imbriquées

Activez la feuille de calcul nommée Conditionnelles imbriquées.

Tableau 2.1 : Saisissez la formule permettant d’afficher le texte Ajourné pour les étudiants ayant moins de 8, Admis pour ceux ayant au moins 10 et Rattrapage pour les autres.

A
B
C
4
Étudiant
Note
Formule
5
Bidule
11
Admis
6
Machin
9
Rattrapage
7
Truc
7
Ajourné
Solution :

Voici les formules à saisir afin d’obtenir le résultat attendu.

A
B
C
4
Étudiant
Note
Formule
5
Bidule
11
=SI(B5<8; »Ajourné »;SI(B5<10; »Rattrapage »; »Admis »))
6
Machin
9
=SI(B6<8; »Ajourné »;SI(B6<10; »Rattrapage »; »Valide »))
7
Truc
7
=SI(B7<8; »Ajourné »;SI(B7<10; »Rattrapage »; »Valide »))

Tableau 2.2 : Saisissez la formule permettant de calculer le nouveau prix en fonction des ristournes A, B ou C équivalant à 10, 20 ou 30 euros.

A
B
C
10
Prix
Ristourne
Formule
11
100
A
90
12
100
B
80
13
100
C
70
Solution :

Voici les formules à saisir afin d’obtenir le résultat attendu.

A
B
C
10
Prix
Ristourne
Formule
11
100
A
=SI(B11= »A »;A11-10;SI(B11= »B »;A11-20;A11-30))
12
100
B
=SI(B12= »A »;A12-10;SI(B12= »B »;A12-20;A12-30))
13
100
C
=SI(B13= »A »;A13-10;SI(B13= »B »;A13-20;A13-30))

Cette formule peut être simplifiée : =A11+SI(B11="A";-10;SI(B11="B";-20;-30))

Tableau 2.3 : Saisissez la formule permettant d’afficher le texte Ajourné pour les étudiants ayant une moyenne inférieure à 8, Admis pour ceux ayant une moyenne supérieure ou égale à 10 et Rattrapage pour les autres.

A
B
C
D
16
Étudiant
Note 1
Note 2
Formule
17
Bidule
11
10
Admis
18
Machin
8
9
Rattrapage
19
Truc
6
7
Ajourné
Solution :

Voici les formules à saisir afin d’obtenir le résultat attendu.

A
B
C
D
16
Étudiant
Note 1
Note 2
Formule
17
Bidule
11
10
=SI(MOYENNE(B17:C17)<8; »Ajourné »;SI(MOYENNE(B17:C17)<10; »Rattrapage »; »Admis »))
18
Machin
8
9
=SI(MOYENNE(B18:C18)<8; »Ajourné »;SI(MOYENNE(B18:C18)<10; »Rattrapage »; »Admis »))
19
Truc
6
7
=SI(MOYENNE(B19:C19)<8; »Ajourné »;SI(MOYENNE(B19:C19)<10; »Rattrapage »; »Admis »))

Tableau 2.4 : Saisissez la formule permettant d’afficher la moyenne suivie du texte Ajourné pour les étudiants ayant une moyenne inférieure à 8, Admis pour ceux ayant une moyenne supérieure ou égale à 10 et Rattrapage pour les autres.

A
B
C
D
22
Étudiant
Note 1
Note 2
Formule
23
Bidule
11
10
10,5 (Admis)
24
Machin
8
9
8,5 (Rattrapage)
25
Truc
6
7
6,5 (Ajourné)
Solution :

Voici les formules à saisir afin d’obtenir le résultat attendu.

A
B
C
D
22
Étudiant
Note 1
Note 2
Formule
23
Bidule
11
10
=MOYENNE(B23:C23)& » (« &SI(MOYENNE(B23:C23)<8; »Ajourné »;SI(MOYENNE(B23:C23)<10; »Rattrapage »; »Admis »))& ») »
24
Machin
8
9
=MOYENNE(B24:C24)& » (« &SI(MOYENNE(B24:C24)<8; »Ajourné »;SI(MOYENNE(B24:C24)<10; »Rattrapage »; »Admis »))& ») »
25
Truc
6
7
=MOYENNE(B25:C25)& » (« &SI(MOYENNE(B25:C25)<8; »Ajourné »;SI(MOYENNE(B25:C25)<10; »Rattrapage »; »Admis »))& ») »

Sauf mention contraire*, l'article Conditionnelles, fonction SI() TAB03 et son contenu par Julien Crego sont mis à disposition selon les termes de la licence Creative Commons

Licence Creative Commons

Attribution - Pas d’Utilisation Commerciale - Partage dans les Mêmes Conditions 4.0 International

Cette licence vous permet de remixer, arranger, et adapter cette œuvre à des fins non commerciales tant que vous créditez la source en citant le nom des auteurs et que les nouvelles œuvres sont diffusées selon les mêmes conditions.

* Cette notice est intégrée automatiquement à la fin de chaque article de ce site.

S’abonner
Notification pour
guest

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

0 Commentaires
Le plus ancien
Le plus récent Le plus populaire
Commentaires en ligne
Afficher tous les commentaires