Références sur un tableur TAB12

Cet exercice concerne les calculs de base et l’usage de fonctions simples sur un tableur.

Consignes de l’exercice

Téléchargez le fichier de travail en cliquant sur le bouton ci-dessous.

Pour télécharger un fichier, faites un clic droit sur le fichier désiré et choisissez l’option Télécharger.
Pour télécharger plusieurs fichiers, sélectionnez les fichiers désirés puis cliquez sur Télécharger les sélectionnés. Les fichiers seront téléchargés sous la forme d’une archive .zip. Veillez à bien extraire le contenu de l’archive avant de commencer à travailler.

Ouvrez le fichier téléchargé avec l’application de votre choix (Microsoft Excel ou LibreOffice Calc).

Si elle n’est pas déjà active, activez la feuille de calculs Références.

Tableau 1 : Dans la cellule C5, saisissez la formule permettant d’additionner les deux nombres des cellules A5 et B5. Pour cette formule, vous devez utiliser l’opérateur +.

A
B
C
4
Nombre 1
Nombre 2
Formule
5
10
5
15
Solution :

Il s’agit pour cette question d’utiliser une addition simple avec l’opérateur + et d’utiliser des références relatives aux deux cellules.

A
B
C
4
Nombre 1
Nombre 2
Formule
5
10
5
=A5+B5

Tableau 1 : Utilisez la poignée de recopie pour reproduire la formule pour toutes les valeurs du tableau 1.

A
B
C
4
Nombre 1
Nombre 2
Formule
5
10
5
15
6
75
25
100
7
100
65
165
8
45
90
135
9
34
54
88
10
56
43
99
Solution :

Pour

Sélectionnez la cellule à recopier.

Cliquez et glissez avec le carré en bas à droite de la cellule sélectionnée.

Démonstration de la poignée de recopie

Les références de la formule se sont mises à jour lors de la recopie afin d’effectuer le calcul pour chacune des lignes.

Tableau 2 : Complétez le tableau avec une formule utilisant la fonction SOMME(). La formule doit être la plus courte possible.

A
B
C
D
13
Nombre 1
Nombre 2
Nombre 3
Formule
14
5
10
2
20
15
10
24
10
44
16
101
65
15
181
17
45
93
20
158
18
30
30
30
90
Solution :

Il s’agit pour cette question d’utiliser la fonction SOMME() avec comme référence, une plage de cellules.

A
B
C
D
13
Nombre 1
Nombre 2
Nombre 3
Formule
14
5
10
2
=SOMME(A14:C14)
15
10
24
10
=SOMME(A15:C15)
16
101
65
15
=SOMME(A16:C16)
17
45
93
20
=SOMME(A17:C17)
18
30
30
30
=SOMME(A18:C18)

Pour faire référence à une plage de cellules, il s’agit de saisir la référence de la première cellule et de la dernière en les séparant par :.

Exemple : A14:C14.

Tableau 3 : Complétez le tableau avec une formule afin de diviser chacun des nombres par le diviseur de la cellule A21. Le caractère à utiliser pour une division est le /.

A
B
C
21
Diviseur
Nombre
Formule
22
5
10
2
23
15
3
24
30
6
25
45
9
26
78
15
Solution :

Pour cette question, la référence à la cellule A22 ne doit pas se mettre à jour lors de la recopie de la formule. Il s’agit donc d’utiliser une référence absolue.

A
B
C
21
Diviseur
Nombre
Formule
22
5
10
=B22/$A$22
23
15
=B23/$A$22
24
30
=B24/$A$22
25
45
=B25/$A$22
26
78
=B26/$A$22

Dans cette formule, seules les références aux cellules de la colonne B se mettent à jour lors de la recopie.

Contrairement aux références relatives, les références absolues ont des coordonnées verrouillées par le symbole $. Il y a donc un $ devant le numéro de la colonne et un autre devant le numéro de la ligne, comme par exemple $A$22.

Ainsi, elles ne se mettent jamais à jour lors de la recopie ou lors d’un simple copier/coller.

Tableau 4 : Complétez le tableau avec une formule permettant d’additionner le nombre de la rangée 29 avec ceux de la rangée 30.

A
B
C
D
E
29
Nombre 1
4
30
Nombre 2
10
12
25
39
31
Formule
14
16
29
43
Solution :

Pas de difficultés particulières pour cette question, il s’agit juste de recopier la formule vers la droite plutôt que vers le bas.

A
B
C
D
E
29
Nombre 1
4
30
Nombre 2
10
12
25
39
31
Formule
=$B$29+B30
=$B$29+C30
=$B$29+D30
=$B$29+E30

Quel que soit le sens de recopie, les références absolues restent fixes.

Tableau 5 : Complétez la cellule C35 afin d’afficher la valeur de la cellule A7 de la feuille de calculs Valeurs.

A
B
34
Référence
Formule
35
Valeurs > A7
100
36
45
37
34
Solution :

Cette question consiste à faire référence à une cellule sur une autre feuille.

A
B
34
Référence
Formule
35
Valeurs > A7
=Valeurs!A7
36
=Valeurs!A8
37
=Valeurs!A9

Les références entre feuille fonctionnent comme des références classiques, mais elles sont précédées du nom de la feuille et d’un !.

Par exemple : Valeurs!A7.

Si le nom de la feuille contient des espaces, il faut alors mettre sont nom entre guillemets : 'Valeurs exemple'!A7.

Tableau 7 et 8 : Saisissez une formule dans la cellule B54 permettant d’additionner les cellules B47 et B52. Votre formule doit pouvoir être recopiée et s’adapter pour l’ensemble des deux lignes de formule. Le nombre de la ligne 1 du tableau 7 sera additionné à tous les nombres de la ligne 1 du tableau 8. Le nombre de la ligne 2 du tableau 7 sera additionné à tous les nombres de la ligne 2 du tableau 8.

A
B
C
D
E
51
Nombre 2
Nombre 3
Nombre 4
Nombre 5
52
Ligne 1
1
4
10
12
53
Ligne 2
1
4
12
20
54
Formule 1
11
14
20
22
55
Formule 2
21
24
32
40
Solution :

Pour pouvoir traiter cette question, il s’agit d’utiliser une référence mixte.

A
B
C
D
E
51
Nombre 2
Nombre 3
Nombre 4
Nombre 5
52
Ligne 1
1
4
10
12
53
Ligne 2
1
4
12
20
54
Formule 1
=$B47+B52
=$B47+C52
=$B47+D52
=$B47+E52
55
Formule 2
=$B48+B53
=$B48+C53
=$B48+D53
=$B48+E53

Dans le cas d’une référence mixte, seule une des deux coordonnées de la référence se met à jour lors de la recopie. La coordonnée verrouillée par un $ reste fixe.

Sauf mention contraire*, l'article Références sur un tableur [TAB12] et son contenu par Julien Crego sont mis à disposition selon les termes de la licence Creative Commons

Licence Creative Commons

Attribution - Pas d’Utilisation Commerciale - Partage dans les Mêmes Conditions 4.0 International

Cette licence vous permet de remixer, arranger, et adapter cette œuvre à des fins non commerciales tant que vous créditez la source en citant le nom des auteurs et que les nouvelles œuvres sont diffusées selon les mêmes conditions.

* Cette notice est intégrée automatiquement à la fin de chaque article de ce site.

S’abonner
Notification pour
guest

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.

0 Commentaires
Commentaires en ligne
Afficher tous les commentaires